Resolving: WordPress’ utf8mb4 support requires MySQL client library (libmysql) version 5.5.3 or newer.

Case: Running a WordPress 6.1.3 install on a cPanel shared web hosting. The page on WP-Admin -> Tools -> Site Health suggests “utf8mb4 requires newer client library”.

Solution

  1. Visit cPanel -> Select PHP Version
  2. The page should show PHP Version drop-down and a list of PHP extensions.
  3. Disable mysqli
  4. Enable nd_mysqli
  5. Save settings.

Source

  1. Verpex.com technical support

Disclaimer

This post contains an affiliate link that refers you to an online resource I’m using. If you visit it and make a purchase, I will receive a small commission at no additional cost to you.

Did this solve your issue?